Welcome to the Kokua/Imprudence Q&A! Here you can ask questions and receive answers from other members of the community.

Run on FreeBSD

0 like 0 dislike
I have PC-BSD 9.0 x64 and would like to run Imprudence on it. Any suggestions would be great. Thanks.
asked Feb 19, 2012 in Imprudence Viewer by anonymous

1 Answer

0 like 0 dislike
I'd first try whether one of our Linux builds works for that. (Although MacOS has a UNIX core, I guess the Mac builds won't work on any BSD flavor.) If not, you'll probably have to build Imprudence yourself for BSD. Instructions for building on Windows, Mac and Linux can be found on http://wiki.kokuaviewer.org/wiki/Imprudence:Compiling . For building on (and for) BSD, you'll have to figure things out yourself but these instructions might help with that.

If I remember correctly, there was someone building the Second Life Viewer (or was it Snowglobe? No, I think that was even before that) for some BSD a loooong time ago. Even though viewers have changed a lot since then, their old posts on https://lists.secondlife.com/pipermail/sldev/ or https://lists.secondlife.com/pipermail/opensource-dev/ might still have valuable hints.
answered Feb 24, 2012 by Boroondas Gupte (820 points)
Privacy policy
...